// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mU)(https:\/\/|http:\/\/).+\..+\/|(http\:\/\/|)localhost(\:(\d+$))").unwrap();
let string = "https://dev.combustion911.com/products/industrial-gas-valves/solenoid/vmr-vml/
localhost:8080";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}