$re = '/(https:\/\/|http:\/\/).+\..+\/|(http\:\/\/|)localhost(\:(\d+$))/mU';
$str = 'https://dev.combustion911.com/products/industrial-gas-valves/solenoid/vmr-vml/
localhost:8080';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);