using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https:\/\/|http:\/\/).+\..+\/|(http\:\/\/|)localhost(\:(\d+$))";
string input = @"https://dev.combustion911.com/products/industrial-gas-valves/solenoid/vmr-vml/
localhost:8080";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}