const regex = /(https:\/\/|http:\/\/).+\..+\/|(http\:\/\/|)localhost(\:(\d+$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https:\\\/\\\/|http:\\\/\\\/).+\\..+\\\/|(http\\:\\\/\\\/|)localhost(\\:(\\d+$))', 'gm')
const str = `https://dev.combustion911.com/products/industrial-gas-valves/solenoid/vmr-vml/
localhost:8080`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}