import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https:\\/\\/|http:\\/\\/).+\\..+\\/|(http\\:\\/\\/|)localhost(\\:(\\d+$))";
final String string = "https://dev.combustion911.com/products/industrial-gas-valves/solenoid/vmr-vml/\n\n"
+ "localhost:8080";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}