re = /\G((?:.\D)*.)\d/
str = 'a1b2cde3~g45hi6
Match any char with a non digit ( This is to ensure that the /G carries on to the next pair)
store any char in \\1
Match any digit'
subst = '$1*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result