$re = '/\G((?:.\D)*.)\d/';
$str = 'a1b2cde3~g45hi6
Match any char with a non digit ( This is to ensure that the /G carries on to the next pair)
store any char in \\1
Match any digit';
$subst = "$1*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;