using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\G((?:.\D)*.)\d";
string substitution = @"$1*";
string input = @"a1b2cde3~g45hi6
Match any char with a non digit ( This is to ensure that the /G carries on to the next pair)
store any char in \1
Match any digit";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}