#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\G((?:.\D)*.)\d"
Local $sString = "a1b2cde3~g45hi6" & @CRLF & _
"" & @CRLF & _
"Match any char with a non digit ( This is to ensure that the /G carries on to the next pair)" & @CRLF & _
"store any char in \1" & @CRLF & _
"Match any digit"
Local $sSubst = "$1*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)