const regex = /\G((?:.\D)*.)\d/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\G((?:.\\D)*.)\\d', 'g')
const str = `a1b2cde3~g45hi6
Match any char with a non digit ( This is to ensure that the /G carries on to the next pair)
store any char in \\1
Match any digit`;
const subst = `$1*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);