// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https:\/\/us[0-9]+\.zopim\.com\/s\/w\/spm\/[0-9a-zA-Z]+\/c\/[0-9]+").unwrap();
let string = "https://us24.zopim.com/s/w/spm/2mwsw010ht6a3jdk/c/1507617726879
https://us34.zopim.com/s/w/spm/rtyortahxceczngb/c/1507618624653
https://us24.zopim.com/s/w/spm/2mwsw010ht6a3jdk/c/1507617726879";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}