import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/us[0-9]+\\.zopim\\.com\\/s\\/w\\/spm\\/[0-9a-zA-Z]+\\/c\\/[0-9]+";
final String string = "https://us24.zopim.com/s/w/spm/2mwsw010ht6a3jdk/c/1507617726879\n"
+ "https://us34.zopim.com/s/w/spm/rtyortahxceczngb/c/1507618624653\n"
+ "https://us24.zopim.com/s/w/spm/2mwsw010ht6a3jdk/c/1507617726879";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}