const regex = /https:\/\/us[0-9]+\.zopim\.com\/s\/w\/spm\/[0-9a-zA-Z]+\/c\/[0-9]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/us[0-9]+\\.zopim\\.com\\\/s\\\/w\\\/spm\\\/[0-9a-zA-Z]+\\\/c\\\/[0-9]+', 'gm')
const str = `https://us24.zopim.com/s/w/spm/2mwsw010ht6a3jdk/c/1507617726879
https://us34.zopim.com/s/w/spm/rtyortahxceczngb/c/1507618624653
https://us24.zopim.com/s/w/spm/2mwsw010ht6a3jdk/c/1507617726879`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}