use strict;
my $str = 'https://us24.zopim.com/s/w/spm/2mwsw010ht6a3jdk/c/1507617726879
https://us34.zopim.com/s/w/spm/rtyortahxceczngb/c/1507618624653
https://us24.zopim.com/s/w/spm/2mwsw010ht6a3jdk/c/1507617726879';
my $regex = qr/https:\/\/us[0-9]+\.zopim\.com\/s\/w\/spm\/[0-9a-zA-Z]+\/c\/[0-9]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}