re = /https:\/\/us[0-9]+\.zopim\.com\/s\/w\/spm\/[0-9a-zA-Z]+\/c\/[0-9]+/m
str = 'https://us24.zopim.com/s/w/spm/2mwsw010ht6a3jdk/c/1507617726879
https://us34.zopim.com/s/w/spm/rtyortahxceczngb/c/1507618624653
https://us24.zopim.com/s/w/spm/2mwsw010ht6a3jdk/c/1507617726879'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end