// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*(?<mac>\w{4}\.\w{4}\.\w{4})\s*(?<vlan>\d*)\s*(?<type>\w*)\s*(?<port>(\w|-|\/|:|\d*)*)\s*(?<vc>\w*\s*\d*)\s*(?<time>(\w|-|\/|:|\d*)*)$").unwrap();
let string = " ac9e.1797.b9f3 1007 Dynamic gpon-onu_1/2/7:1 vport 1 N/A";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}