const regex = /^\s*(?<mac>\w{4}\.\w{4}\.\w{4})\s*(?<vlan>\d*)\s*(?<type>\w*)\s*(?<port>(\w|-|\/|:|\d*)*)\s*(?<vc>\w*\s*\d*)\s*(?<time>(\w|-|\/|:|\d*)*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(?<mac>\\w{4}\\.\\w{4}\\.\\w{4})\\s*(?<vlan>\\d*)\\s*(?<type>\\w*)\\s*(?<port>(\\w|-|\\\/|:|\\d*)*)\\s*(?<vc>\\w*\\s*\\d*)\\s*(?<time>(\\w|-|\\\/|:|\\d*)*)$', 'gm')
const str = ` ac9e.1797.b9f3 1007 Dynamic gpon-onu_1/2/7:1 vport 1 N/A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}