package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*(?<mac>\w{4}\.\w{4}\.\w{4})\s*(?<vlan>\d*)\s*(?<type>\w*)\s*(?<port>(\w|-|\/|:|\d*)*)\s*(?<vc>\w*\s*\d*)\s*(?<time>(\w|-|\/|:|\d*)*)$`)
var str = ` ac9e.1797.b9f3 1007 Dynamic gpon-onu_1/2/7:1 vport 1 N/A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}