use strict;
my $str = ' ac9e.1797.b9f3 1007 Dynamic gpon-onu_1/2/7:1 vport 1 N/A';
my $regex = qr/^\s*(?<mac>\w{4}\.\w{4}\.\w{4})\s*(?<vlan>\d*)\s*(?<type>\w*)\s*(?<port>(\w|-|\/|:|\d*)*)\s*(?<vc>\w*\s*\d*)\s*(?<time>(\w|-|\/|:|\d*)*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}