import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?<mac>\\w{4}\\.\\w{4}\\.\\w{4})\\s*(?<vlan>\\d*)\\s*(?<type>\\w*)\\s*(?<port>(\\w|-|\\/|:|\\d*)*)\\s*(?<vc>\\w*\\s*\\d*)\\s*(?<time>(\\w|-|\\/|:|\\d*)*)$";
final String string = " ac9e.1797.b9f3 1007 Dynamic gpon-onu_1/2/7:1 vport 1 N/A";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}