# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^ver(ä|a)ntwortlich(er)?\.?\s+g(em((ä|a)(ß|s{1,2})?)?)?\.?\s+a(rt(ikel)?)?\.?"
test_str = ("Verantwortlicher gemäß Art\n"
"Verantwortlicher gemäß. Art.\n"
"Verantwortlicher gemäss Art\n"
"Verantwortlicher gemäs art\n"
"Verantwortlicher gemaß Art\n"
"Verantwortlicher gemä Art\n"
"Verantwortlicher. gem A.\n"
"Verantwortlicher gem Art\n"
"Verantwortlicher g. A.\n"
"Verantwortlicher g Artikel.\n"
"Verantwortlicher g Art\n"
"Verantwortlicher gemass Artikel\n"
"Verantwortlicher g Artikel\n"
"Verantwortlicher gemass Artikel\n"
"Verantwortlich. gemass Artikel\n"
"Verantwortlich gemass Artikel\n\n\n"
"^\n"
"verantwortlicher\n"
"\\s+\n"
"g(em((ä|a)(ß|s+)?)?)?\\.?\n"
"\\s+\n"
"a(rt(ikel)?)?\\.?\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.UNICODE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.