import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ver(ä|a)ntwortlich(er)?\\.?\\s+g(em((ä|a)(ß|s{1,2})?)?)?\\.?\\s+a(rt(ikel)?)?\\.?";
final String string = "Verantwortlicher gemäß Art\n"
+ "Verantwortlicher gemäß. Art.\n"
+ "Verantwortlicher gemäss Art\n"
+ "Verantwortlicher gemäs art\n"
+ "Verantwortlicher gemaß Art\n"
+ "Verantwortlicher gemä Art\n"
+ "Verantwortlicher. gem A.\n"
+ "Verantwortlicher gem Art\n"
+ "Verantwortlicher g. A.\n"
+ "Verantwortlicher g Artikel.\n"
+ "Verantwortlicher g Art\n"
+ "Verantwortlicher gemass Artikel\n"
+ "Verantwortlicher g Artikel\n"
+ "Verantwortlicher gemass Artikel\n"
+ "Verantwortlich. gemass Artikel\n"
+ "Verantwortlich gemass Artikel\n\n\n"
+ "^\n"
+ "verantwortlicher\n"
+ "\\s+\n"
+ "g(em((ä|a)(ß|s+)?)?)?\\.?\n"
+ "\\s+\n"
+ "a(rt(ikel)?)?\\.?\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}