$re = '/^ver(ä|a)ntwortlich(er)?\.?\s+g(em((ä|a)(ß|s{1,2})?)?)?\.?\s+a(rt(ikel)?)?\.?/miu';
$str = 'Verantwortlicher gemäß Art
Verantwortlicher gemäß. Art.
Verantwortlicher gemäss Art
Verantwortlicher gemäs art
Verantwortlicher gemaß Art
Verantwortlicher gemä Art
Verantwortlicher. gem A.
Verantwortlicher gem Art
Verantwortlicher g. A.
Verantwortlicher g Artikel.
Verantwortlicher g Art
Verantwortlicher gemass Artikel
Verantwortlicher g Artikel
Verantwortlicher gemass Artikel
Verantwortlich. gemass Artikel
Verantwortlich gemass Artikel
^
verantwortlicher
\\s+
g(em((ä|a)(ß|s+)?)?)?\\.?
\\s+
a(rt(ikel)?)?\\.?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);