use strict;
my $str = 'Verantwortlicher gemäß Art
Verantwortlicher gemäß. Art.
Verantwortlicher gemäss Art
Verantwortlicher gemäs art
Verantwortlicher gemaß Art
Verantwortlicher gemä Art
Verantwortlicher. gem A.
Verantwortlicher gem Art
Verantwortlicher g. A.
Verantwortlicher g Artikel.
Verantwortlicher g Art
Verantwortlicher gemass Artikel
Verantwortlicher g Artikel
Verantwortlicher gemass Artikel
Verantwortlich. gemass Artikel
Verantwortlich gemass Artikel
^
verantwortlicher
\\s+
g(em((ä|a)(ß|s+)?)?)?\\.?
\\s+
a(rt(ikel)?)?\\.?
';
my $regex = qr/^ver(ä|a)ntwortlich(er)?\.?\s+g(em((ä|a)(ß|s{1,2})?)?)?\.?\s+a(rt(ikel)?)?\.?/miup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}