const regex = /^ver(ä|a)ntwortlich(er)?\.?\s+g(em((ä|a)(ß|s{1,2})?)?)?\.?\s+a(rt(ikel)?)?\.?/gmiu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ver(ä|a)ntwortlich(er)?\\.?\\s+g(em((ä|a)(ß|s{1,2})?)?)?\\.?\\s+a(rt(ikel)?)?\\.?', 'gmiu')
const str = `Verantwortlicher gemäß Art
Verantwortlicher gemäß. Art.
Verantwortlicher gemäss Art
Verantwortlicher gemäs art
Verantwortlicher gemaß Art
Verantwortlicher gemä Art
Verantwortlicher. gem A.
Verantwortlicher gem Art
Verantwortlicher g. A.
Verantwortlicher g Artikel.
Verantwortlicher g Art
Verantwortlicher gemass Artikel
Verantwortlicher g Artikel
Verantwortlicher gemass Artikel
Verantwortlich. gemass Artikel
Verantwortlich gemass Artikel
^
verantwortlicher
\\s+
g(em((ä|a)(ß|s+)?)?)?\\.?
\\s+
a(rt(ikel)?)?\\.?
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}