import Foundation
let pattern = #"([0-9]+)\/([0-9]+)\/(?P<Tc>[0-9]+|-1)\/([0-9]+)\/(?P<Ta>[0-9]+|-1)\s(?P<Code>[0-9]+|-1)\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ####"""
dhadkadhadka 12/2/34/3/3 200 343948938 dhakdhadhak 32382 ### si verifica in modalita http
dhadkadhadka 12/2/-1/3/3 503 343948938 dhakdhadhak 32382 ###timeout
dhadkadhadka 1/0/60053 185 343948938 dhakdhadhak 32382 ###si verifica in modalita tcp
dhadkadhadka 12/2/34 200 343948938 dhakdhadhak 32382 ###non si verifica
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)