re = /([0-9]+)\/([0-9]+)\/(?P<Tc>[0-9]+|-1)\/([0-9]+)\/(?P<Ta>[0-9]+|-1)\s(?P<Code>[0-9]+|-1)\s/m
str = 'dhadkadhadka 12/2/34/3/3 200 343948938 dhakdhadhak 32382 ### si verifica in modalita http
dhadkadhadka 12/2/-1/3/3 503 343948938 dhakdhadhak 32382 ###timeout
dhadkadhadka 1/0/60053 185 343948938 dhakdhadhak 32382 ###si verifica in modalita tcp
dhadkadhadka 12/2/34 200 343948938 dhakdhadhak 32382 ###non si verifica'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end