use strict;
my $str = 'dhadkadhadka 12/2/34/3/3 200 343948938 dhakdhadhak 32382 ### si verifica in modalita http
dhadkadhadka 12/2/-1/3/3 503 343948938 dhakdhadhak 32382 ###timeout
dhadkadhadka 1/0/60053 185 343948938 dhakdhadhak 32382 ###si verifica in modalita tcp
dhadkadhadka 12/2/34 200 343948938 dhakdhadhak 32382 ###non si verifica';
my $regex = qr/([0-9]+)\/([0-9]+)\/(?P<Tc>[0-9]+|-1)\/([0-9]+)\/(?P<Ta>[0-9]+|-1)\s(?P<Code>[0-9]+|-1)\s/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}