#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9]+)\/([0-9]+)\/(?P<Tc>[0-9]+|-1)\/([0-9]+)\/(?P<Ta>[0-9]+|-1)\s(?P<Code>[0-9]+|-1)\s"
Local $sString = "dhadkadhadka 12/2/34/3/3 200 343948938 dhakdhadhak 32382 ### si verifica in modalita http" & @CRLF & _
"" & @CRLF & _
"dhadkadhadka 12/2/-1/3/3 503 343948938 dhakdhadhak 32382 ###timeout" & @CRLF & _
"dhadkadhadka 1/0/60053 185 343948938 dhakdhadhak 32382 ###si verifica in modalita tcp" & @CRLF & _
"dhadkadhadka 12/2/34 200 343948938 dhakdhadhak 32382 ###non si verifica"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")