import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]+)\\/([0-9]+)\\/(?P<Tc>[0-9]+|-1)\\/([0-9]+)\\/(?P<Ta>[0-9]+|-1)\\s(?P<Code>[0-9]+|-1)\\s";
final String string = "dhadkadhadka 12/2/34/3/3 200 343948938 dhakdhadhak 32382 ### si verifica in modalita http\n\n"
+ "dhadkadhadka 12/2/-1/3/3 503 343948938 dhakdhadhak 32382 ###timeout\n"
+ "dhadkadhadka 1/0/60053 185 343948938 dhakdhadhak 32382 ###si verifica in modalita tcp\n"
+ "dhadkadhadka 12/2/34 200 343948938 dhakdhadhak 32382 ###non si verifica";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}