import Foundation
let pattern = #"(?<!BM.)(?<=\W)(SetColor|SetAlpha|DrawRect|Delay|Flip|SetScale|SetVirtualResolution|CloseStream|GraphicsWidth|GraphicsHeight|VirtualResolutionWidth|VirtualResolutionHeight)(?=\W)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SetColor(0, 0, 0);
Delay(10);
Flip();
SetColor(0, 0, 0);
SetAlpha(- float(n) / Fade1);
DrawRect(0, 0,tApplication.ScrW(),tApplication.ScrH());
BM.SetAlpha(1);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"BM.$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)