const regex = /(?<!BM.)(?<=\W)(SetColor|SetAlpha|DrawRect|Delay|Flip|SetScale|SetVirtualResolution|CloseStream|GraphicsWidth|GraphicsHeight|VirtualResolutionWidth|VirtualResolutionHeight)(?=\W)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!BM.)(?<=\\W)(SetColor|SetAlpha|DrawRect|Delay|Flip|SetScale|SetVirtualResolution|CloseStream|GraphicsWidth|GraphicsHeight|VirtualResolutionWidth|VirtualResolutionHeight)(?=\\W)', 'gm')
const str = `
SetColor(0, 0, 0);
Delay(10);
Flip();
SetColor(0, 0, 0);
SetAlpha(- float(n) / Fade1);
DrawRect(0, 0,tApplication.ScrW(),tApplication.ScrH());
BM.SetAlpha(1);
`;
const subst = `BM.$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);