use strict;
my $str = '
SetColor(0, 0, 0);
Delay(10);
Flip();
SetColor(0, 0, 0);
SetAlpha(- float(n) / Fade1);
DrawRect(0, 0,tApplication.ScrW(),tApplication.ScrH());
BM.SetAlpha(1);
';
my $regex = qr/(?<!BM.)(?<=\W)(SetColor|SetAlpha|DrawRect|Delay|Flip|SetScale|SetVirtualResolution|CloseStream|GraphicsWidth|GraphicsHeight|VirtualResolutionWidth|VirtualResolutionHeight)(?=\W)/mp;
my $subst = 'BM.$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";