$re = '/(?<!BM.)(?<=\W)(SetColor|SetAlpha|DrawRect|Delay|Flip|SetScale|SetVirtualResolution|CloseStream|GraphicsWidth|GraphicsHeight|VirtualResolutionWidth|VirtualResolutionHeight)(?=\W)/m';
$str = '
SetColor(0, 0, 0);
Delay(10);
Flip();
SetColor(0, 0, 0);
SetAlpha(- float(n) / Fade1);
DrawRect(0, 0,tApplication.ScrW(),tApplication.ScrH());
BM.SetAlpha(1);
';
$subst = "BM.$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;