import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!BM.)(?<=\\W)(SetColor|SetAlpha|DrawRect|Delay|Flip|SetScale|SetVirtualResolution|CloseStream|GraphicsWidth|GraphicsHeight|VirtualResolutionWidth|VirtualResolutionHeight)(?=\\W)";
final String string = "\n"
+ "SetColor(0, 0, 0);\n"
+ " Delay(10);\n"
+ " Flip();\n"
+ " SetColor(0, 0, 0);\n"
+ " SetAlpha(- float(n) / Fade1);\n"
+ " DrawRect(0, 0,tApplication.ScrW(),tApplication.ScrH());\n"
+ " BM.SetAlpha(1);\n";
final String subst = "BM.$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}