// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d{2}\.\d{2}\.\d{4} ( \- \d{2}\.\d{2}\.\d{4})? ($|,)").unwrap();
let string = "01.02.1998,
01.02.1998-03.03.2001,
01.02.1998 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}