import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{2}\\.\\d{2}\\.\\d{4} ( \\- \\d{2}\\.\\d{2}\\.\\d{4})? ($|,)";
final String string = "01.02.1998, \n"
+ "01.02.1998-03.03.2001,\n"
+ "01.02.1998 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}