#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{2}\.\d{2}\.\d{4} ( \- \d{2}\.\d{2}\.\d{4})? ($|,)"
Local $sString = "01.02.1998, " & @CRLF & _
"01.02.1998-03.03.2001," & @CRLF & _
"01.02.1998 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")