package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{2}\.\d{2}\.\d{4} ( \- \d{2}\.\d{2}\.\d{4})? ($|,)`)
var str = `01.02.1998,
01.02.1998-03.03.2001,
01.02.1998 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}