re = /\d{2}\.\d{2}\.\d{4} ( \- \d{2}\.\d{2}\.\d{4})? ($|,)/
str = '01.02.1998,
01.02.1998-03.03.2001,
01.02.1998 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end