import Foundation
let pattern = #"^[A-Za-zÀ-ÖØ-ö_ø-ÿ][\wÀ-ÖØ-ö_ø-ÿ \.\'\-]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
8 fg
e8riééééééé
a gi- d d'alroe
érien4
f kr
04b
n44
k kl *+
adrien
d'Al Meida
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)