package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-zÀ-ÖØ-ö_ø-ÿ][\wÀ-ÖØ-ö_ø-ÿ \.\'\-]*$`)
var str = `8 fg
e8riééééééé
a gi- d d'alroe
érien4
f kr
04b
n44
k kl *+
adrien
d'Al Meida
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}