#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-zÀ-ÖØ-ö_ø-ÿ][\wÀ-ÖØ-ö_ø-ÿ \.\'\-]*$"
Local $sString = "8 fg" & @CRLF & _
"e8riééééééé" & @CRLF & _
"a gi- d d'alroe" & @CRLF & _
"érien4" & @CRLF & _
"f kr" & @CRLF & _
"04b" & @CRLF & _
"n44" & @CRLF & _
"k kl *+" & @CRLF & _
"adrien" & @CRLF & _
"d'Al Meida" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")