import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-zÀ-ÖØ-ö_ø-ÿ][\\wÀ-ÖØ-ö_ø-ÿ \\.\\'\\-]*$";
final String string = "8 fg\n"
+ "e8riééééééé\n"
+ "a gi- d d'alroe\n"
+ "érien4\n"
+ "f kr\n"
+ "04b\n"
+ "n44\n"
+ "k kl *+\n"
+ "adrien\n"
+ "d'Al Meida\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}