const regex = /^[A-Za-zÀ-ÖØ-ö_ø-ÿ][\wÀ-ÖØ-ö_ø-ÿ \.\'\-]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-zÀ-ÖØ-ö_ø-ÿ][\\wÀ-ÖØ-ö_ø-ÿ \\.\\\'\\-]*$', 'gm')
const str = `8 fg
e8riééééééé
a gi- d d'alroe
érien4
f kr
04b
n44
k kl *+
adrien
d'Al Meida
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}