import Foundation
let pattern = #""Title":"(?<Title>.*?)"."Department":"(?<Department>.*?)"."Name":"(?<Name>.*?)"."Phone":"(?<Phone>.*?)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{"searchRecords":[{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t000034IdzFAAS"},"Title":"Implementation Manager","Department":"Builds","Name":"Erik Leiren","Phone":"2062517122"},{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t00003o8udRAAQ"},"Title":"Medical Assistant","Department":"Medical","Name":"Danielle Johnson","Phone":"(206) 251-7122"},{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t0000408gx2AAA"},"Title":"Platform Engineer","Department":"PE","Name":"Erik J. Leiren","Phone":"2062517122"}]}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)