import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"Title\":\"(?<Title>.*?)\".\"Department\":\"(?<Department>.*?)\".\"Name\":\"(?<Name>.*?)\".\"Phone\":\"(?<Phone>.*?)\"";
final String string = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Contact\",\"url\":\"/services/data/v53.0/sobjects/Contact/0033t000034IdzFAAS\"},\"Title\":\"Implementation Manager\",\"Department\":\"Builds\",\"Name\":\"Erik Leiren\",\"Phone\":\"2062517122\"},{\"attributes\":{\"type\":\"Contact\",\"url\":\"/services/data/v53.0/sobjects/Contact/0033t00003o8udRAAQ\"},\"Title\":\"Medical Assistant\",\"Department\":\"Medical\",\"Name\":\"Danielle Johnson\",\"Phone\":\"(206) 251-7122\"},{\"attributes\":{\"type\":\"Contact\",\"url\":\"/services/data/v53.0/sobjects/Contact/0033t0000408gx2AAA\"},\"Title\":\"Platform Engineer\",\"Department\":\"PE\",\"Name\":\"Erik J. Leiren\",\"Phone\":\"2062517122\"}]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}