package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"Title":"(?<Title>.*?)"."Department":"(?<Department>.*?)"."Name":"(?<Name>.*?)"."Phone":"(?<Phone>.*?)"`)
var str = `{"searchRecords":[{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t000034IdzFAAS"},"Title":"Implementation Manager","Department":"Builds","Name":"Erik Leiren","Phone":"2062517122"},{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t00003o8udRAAQ"},"Title":"Medical Assistant","Department":"Medical","Name":"Danielle Johnson","Phone":"(206) 251-7122"},{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t0000408gx2AAA"},"Title":"Platform Engineer","Department":"PE","Name":"Erik J. Leiren","Phone":"2062517122"}]}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}