$re = '/"Title":"(?<Title>.*?)"."Department":"(?<Department>.*?)"."Name":"(?<Name>.*?)"."Phone":"(?<Phone>.*?)"/m';
$str = '{"searchRecords":[{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t000034IdzFAAS"},"Title":"Implementation Manager","Department":"Builds","Name":"Erik Leiren","Phone":"2062517122"},{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t00003o8udRAAQ"},"Title":"Medical Assistant","Department":"Medical","Name":"Danielle Johnson","Phone":"(206) 251-7122"},{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t0000408gx2AAA"},"Title":"Platform Engineer","Department":"PE","Name":"Erik J. Leiren","Phone":"2062517122"}]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);