#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"Title":"(?<Title>.*?)"."Department":"(?<Department>.*?)"."Name":"(?<Name>.*?)"."Phone":"(?<Phone>.*?)""
Local $sString = "{"searchRecords":[{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t000034IdzFAAS"},"Title":"Implementation Manager","Department":"Builds","Name":"Erik Leiren","Phone":"2062517122"},{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t00003o8udRAAQ"},"Title":"Medical Assistant","Department":"Medical","Name":"Danielle Johnson","Phone":"(206) 251-7122"},{"attributes":{"type":"Contact","url":"/services/data/v53.0/sobjects/Contact/0033t0000408gx2AAA"},"Title":"Platform Engineer","Department":"PE","Name":"Erik J. Leiren","Phone":"2062517122"}]}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")